Home Forums Gardening Questions Choisya

This topic contains 3 replies, has 3 voices, and was last updated by  Frank AKA seasider 2 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #58371

    Frank AKA seasider
    Participant

    I Have a choisya Aztec Pearl which is about 3 years old, it has just got to a nice size about 2.5 ft high and looking ok. I was hoping this year for a good covering of flowers but not so, it has loads of buds but they appear to have stopped, done nothing now for 2 or 3 weeks. I was wondering whether anyone had any idea what the reason is.

    #58373

    Beanstew
    Participant

    The only article I could find that might explain your disappointment is as follows – https://www.rhs.org.uk/advice/profile?PID=627. Given the weather we have had recently, this may well have happened. Can only hope that you won’t have the same next year.

    #58380

    Allan
    Moderator

    There’s a lot of plants that have suffered this year Frank,As Sheila said,Itwent down to—10 Here last winter, So a lot of tropical plants didn’t make it.or just survived without being able to produce flowers and seed,

    #58381

    Frank AKA seasider
    Participant

    Thanks, Allan & Sheila I was wondering if the bad weather in early spring was the cause, we had a cold spell, not as cold as you Allan but living on the coast we had North and East winds which are pretty bad. In fact all the time the rest of the country has been enjoying the summer-like weather with record temperatures we here on the coast have still got the cool Northerlies as Dixon will confirm. Lets hope for better weather to come :notacloudinsight:

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Loading...